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Once you're done converting all the configs you want, make sure to sync to the latest in the Configurations folder in P4

(so you don't blow out anyone else's work) BEFORE clicking on Generate Configurations.
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This is a list of needed tools and a typical day's worth of work flow in Unity/data.

Tools

Support Tools

Unity Add-on Tools
Ramp Brush 

Get from the Unity Asset Store, $10 (reimbursable)
Install in project (don't check in)
In Projects tab in Unity, locate the RampBrush folder and drag RampBrush into the terrain.
In the Inspector tab, hit the Activate/Inactivate Brush button (Lol, I think the author meant Deactivate).

Controls:
Follow the instruction below the Activate button

Photoshop
If you don't have any of the above, contact Lee Tonga, our in-house IT expert

A Json editor. I like Sublime https://www.sublimetext.com/3

Hunt Data

https://www.sublimetext.com/3


Please refer to this document to learn how to enter Hunt Data:   .Hunt Data Setup

Region Data

Regions Under Construction and Test Regions
Coming in 0.5.0:

Regions placed before “0” (negative regions) will have all hunts unlocked by default
Trophy hunts in negative regions will be repeatable

 
 New procedures:

While a region is in development, we need to append the Region sku with “test_“. (i.e. “test_region_9”)
In Regions, we still need to have the region Order to be negative
When a region is ready to be added to progression, remove “test_” from the Sku ID AND turn the negative Order number to a
positive

The game saves progression based on the Region Sku. The reason why we need to rename once its ready to go in is to prevent save issues (the
game would think a developer has already completed all the regions in testing, despite being newly added).

Unity

Unity Add-on Tools
Ramp Brush 

Get from the Unity Asset Store, $10 (reimbursable)
Install in project (don't check in)
In Projects tab in Unity, locate the RampBrush folder and drag RampBrush into the terrain.
In the Inspector tab, hit the Activate/Inactivate Brush button (Lol, I think the author meant Deactivate).

Controls:
Follow the instruction below the Activate button

Unity Hub
If you don't have this, ask a programmer to help you set this up. Check with Sam S. to see if he can spare someone. 
Use this to launch Unity ALWAYS
Target Platform, always choose iOS
Perforce Integration 

Unity has perforce integration. Set it up here:

https://confluence.glu.com/pages/viewpage.action?pageId=72620139


Open the window from Edit > Project Settings...
You'll see the following. Select Editor on the left and look down to Version Control. 

Select Perforce in the dropdown for Mode. 
Fill in your login name/password
Find your Workspace tag from Perforce
Find the server from Perfoce
Connect

Perforce integration is great for automatically checking out your hunt levels. However, Unity does a ton of automatic checkouts.
Just take those files and stick them in their own temp changelist (or when someone asks you to check them in so they can work
on them).

Excel (Microsoft Office) for all of our data work for hunts and animals
Photoshop

If you don't have any of the above, contact Lee Tonga, our in-house IT expert
A Json editor. I like Sublime https://www.sublimetext.com/3

https://www.sublimetext.com/3


UI Setup

Unity Launcher and Perforce Integration

Unity Hub
If you don't have this, ask a programmer to help you set this up. Check with Sam S. to see if he can spare someone. 
Use this to launch Unity ALWAYS
Target Platform, always choose iOS

Perforce - Unity has perforce integration. Set it up here:

Open the window from Edit > Project Settings...
You'll see the following. Select Editor on the left and look down to Version Control. 

Select Perforce in the dropdown for Mode. 
Fill in your login name/password
Find your Workspace tag from Perforce
Find the server from Perfoce
Connect



Perforce integration is great for automatically checking out your hunt levels. However, Unity does a ton of automatic checkouts.
Just take those files and stick them in their own temp changelist (or when someone asks you to check them in so they can work
on them).

Excel (Microsoft Office) for all of our data work for hunts and animals

Unity UI Scheme

Scene - This is the main view window for manipulating gameplay objects.

Hierarchy - All of the gameplay objects, Player Start Positions, Escape Points (under POIs), and AnimalSpawns can be found here. WARNING:
Do not save and definitely do not check in any Environment objects in the "RegionName"_M1_01 hierarchy. 

Mission Editor - (Found under the Tools menu) Our missions or hunts (the two terms are interchangeable) are loaded from this tab. There are
only a few things that are specified here, the Player Spawn Set, Player Spawn Point, Environment, and Awareness time seconds. Nothing else in
there works.

Console - This screen spits out errors. We're mostly concerned with the yellow and red errors. There's a window below where the whole error is
and you copy/paste that.

GluPenPanel - (Found under the Window menu) After a while, some hunts will refuse to load in the game (particularly if you've been doing a lot of
config work). If this happens, hit all 3 buttons to clear all of the caches. Note: Clear PlayerPref will revert your Game Variant name and return it to
its default. You'll need to reapply your Game Variant name and save it. 



Game - This tab is activated automatically when the game starts up. You can switch to Scene and watch the game progress with all of the
Scene's game object info and icons visible (splines, collision boxes, etc). 

Navigation - This shows the navmesh for the entire level. Use this to spot no-pathable holes in the navmesh. Best seen from below the terrain,
looking up, as all of the navmeshes have been sunk -1 meter/unit.

Project - From here, you can access all of the project's files and assets. Use this to rename duplicated hunts, view animal skins or horns/tusks.

UI Window Customization - Each tab can be clicked on/held to drag around the screen. The windows are context sensitive and you can align
the window you have selected to sit side by side with another window, added to it's tab panel, move under another window, etc. Play around with
it to get a configuration you're happy with and keep it that way. I like to keep my Hierarchy next to the Inspector since I do a lot of AnimalSpawn
work from copy/pasting existing hunts. I need to rename the SpawnPoint name and the Spawner ID from the Hierarchy to the Inspector. 

Unity Hotkeys

View Controls

Keystroke Double Speed Command

Q+Right Mouse +Left Shift Elevation Down

E+Right Mouse +Left Shift Elevation Up

A+Right Mouse +Left Shift Pan Left

D+Right Mouse +Left Shift Pan Right

W+Right Mouse +Left Shift Zoom In

S+Right Mouse +Left Shift Zoom Out

Object Controls

W   Move

E   Rotate

R   Scale



T   Rect Tool

Z   Pivot Mode toggle

X   Pivot Rotation Toggle

V   Vertex Snap

CTRL/CMD+LMB   Snap

Edit Controls

Ctrl/Cmd+Z Undo

Cmd+Shift+Z (Mac only) Redo

Ctrl/Cmd+C Copy

Ctrl/Cmd+V Paste

Ctrl/Cmd+D Duplicate

F Frame (centre) selection

Ctrl/Cmd+A Select All

Ctrl/Cmd+P Play

Ctrl/Cmd+Shift+P Pause

Ctrl/Cmd+Alt+P Step

Daily Process

Editing An Existing or Duplicated Hunt

This is the bulk of what LDs do on Deer Hunter. There's a lot of time-saving shortcuts we can take, like copy/pasting spawners from one level to
another to duplicating whole levels and renaming them to make new levels. Of course, you'll have to go in and customize the level to the new
level's requirements. And this is what this section will cover. 

Editing a level requires a two part process. A) Hunt.xlsx edits and B) Unity level edits. 

For editing Hunt_Region_#.xlsx, please follow these instructions .Hunt Data Setup

The following assumes a hunt has been duplicated and renamed.

Player Spawn Point

https://confluence.glu.com/pages/viewpage.action?pageId=72620139


1.  

 

One of the first things to set is the Player Spawn Point. In the Hierarchy, you'll find a subfolder called PlayerSpawnPoints or
"RegionName"PlayerSpawnPoints. Under it, you'll find 3 to 5 SpawnPoints. Each one will correspond with a spawn point in the Scene tab. To set
one of the SpawnPoints as the one to use for a particular hunt, find the Player Spawn Point dropdown selector in the Mission Editor. 

There's a couple things that need to be set for the Player Spawn Point: 1) Height of the spawn point and 2) rotational limits.

Under each spawn point in the Hierarchy, there's a Human_Scale_01 object. Click the checkbox in the Inspector to make it visible. 

Notice the green, red, and blue movement widget. Use the green arrow to move the human scale object up. Align its eyes to the
center of the small square of the spawn point:



1.  

2.  

Now select the main spawn point in the Hierarchy, in this case, it's Spawn4. Now dragging the green arrow down will move both
the start point and the figure at the same time. Lower the start point and the human scale so that the bottoms fo the human
scale's feet a flush with the ground. 

Once the camera/Player Start Point is at the correct height, uncheck the Human_Scale_01 object in the Inspector (this will show
up in the game if you don't uncheck the box)

Camera Rotation Limits are important. Players should be able to rotate the player camera to track animals to their escape points. Never
allow a camera to stop rotating with the animal escaping beyond the rotation limit. 



2.  

a.  

b.  

c.  

With your desired spawn point selected in the Hierarchy, you can set the Camera Rotation Angle. 180 degrees literally means the camera
will rotate exactly 180 degrees. 

Additionally, the Initial Pos On Spline should be set to .5. That will center the start point of the camera at the middle of the
camera spline
Drill down on the spawn point in the Hierarchy to BGCurve and select that. This will also select the camera spline in the Scene
tab where you can edit the spline and position of the start point of the camera. 

Use this to mostly center the starting cam to the second cam



2.  

c.  

While editing/moving objects around, sometimes it's useful to see through the cameras view. To do this:

a) Select the SpawnPoint you want to see through



b) Go to GameObject > Align View to Selected

c) Now the your view should be the selected cameras view

Animal Spawns

Here's the meat of the Deer Hunter level design experience. This is where the designer can script various animals behaviors, where they go, and
where they escape. 



Components of the Unity Animal Spawning and Behavior Scripts
AnimalSpawns:

The AnimalSpawn name should be the same as the Spawner ID (defined in the Hunt_Region_#.xlsx file).

SpawnPoint:
The SpawnPoint is where the animal will spawn in when the level loading procedure populates the hunt. 

The pointed end is the front of the animal.
Spawn points can be rotated using the rotation widget (select the spawn point and hit the E key). 
Make sure they're sitting just above ground. While the engine will know to snap the animals to the ground at run time, it's
best practices to make sure they're on the ground. Especially since the movement splines go off of where the spawn
point is.



BGCurve:
This specifies the animals movement by way of a generated spline.

There are 2 points in a spline, the start and the end.
The start of the spline is at point #0 and the end is at point #1.
Multiple splines can be roughly connected as long as the next spline starts at #0 where the previous spline ends at #1. 
Use the Bezier curve handles to edit the curve of the spline.
New splines can be generated via the Action Queue (more on that next).
You can use the  to see splines at all timesSplinesVisualizer prefab

Search "SplinesVisualizer" in the project tab

Drag and drop onto your scene hierarchy

Now you should be able to view your splines at all times! The visualizer shows a white line

If you don't want to see the white line, just be sure to disable the prefab through the hierarchy



Action Queue

The Action Queue is essentially Deer Hunter's level design scripting tool. This allows LDs to script up a string of behaviors to make the animals
look natural in their environment. 

With the animal selected, the Action Queue will be displayed:



There can be any number of actions the LD can place. 

Go To

Go To adds a spline to the world based on the location of the spawn point or the end of the previous Go To point. 
The generated spline, BGCurve, is the same one associated under the specified animal's name. 
All subsequent splines created via the Go To > Add function, will appear under the previous spline in the Hierarchy tab.



After adding a Go To point and spline, the LD can pick one of 4 options from it's drop down:
Walk
Run
Hobble
Alert
None

Play Animation

Add a Play Animation (or fidget animation) makes the animal play the specified animation. 
Loop count denotes how many times the animal will pay that animation before moving on the next Action Queue item.
The LD can pick any one of 9 animations to play, if supported

Wait
Specifies, in seconds, how long the animal should wait before the next Action Queue item.

Escape
Used to specify that the specified animal should go into escape mode. 
An Escape Point is specified by placing it in the Escape Point Slot

Attack
Specifies (predator only) to attack the player.

Loop
Specifies how often to loop a group of Action Queue items and where to start to the loop



Escape Points

When animals are alerted (if Alertness is toggled to TRUE in Hunt_Region_#.xlsx), it will try to flee to an escape point.

Escape points are always placed out of line of sight of the player. Above, this escape point is well below and behind the ridge top
between it and the player spawn points. 
Spawn points can be toggled on or off from the Inspector tab in the checkbox right under the Inspector tab itself.





Perforce and Checking Out/In Files 

Syncing

At the start of the day, look for a message from QA (Michael McDonald or AJ Chelson) in Slack - deerhunter-team (giving the team the all clear to
sync to trunk). 

Typically, I sync once and that's it. This avoids issues with bad check-ins that'll block some or all of your work. You can safely sync to the Configs
folder to get the latest configs. 

Key Directories & Files

Hunt Files

trunk/Assets/Configs/XLS/Hunts/Hunt_Region_*#*.xlsx
trunk/Assets/Configs/XML/Generated/Hunt.xml
trunk/Assets/Configs/XML/Generated/Spawners.xml
 

Animal Files

trunk/Assets/Configs/XLS/Animals.xlsx
trunk/Assets/Configs/XML/Generated/AnimalAnimationConfigurations.xml
trunk/Assets/Configs/XML/Generated/AnimalBaseConfigurations.xml
trunk/Assets/Configs/XML/Generated/AnimalConfigurations.xml
trunk/Assets/Configs/XML/Generated/AnimalPartConfigurations.xml
 

Region Files

trunk/Assets/Configs/XLS/Regions.xlsx
trunk/Assets/Configs/XML/Generated/PrerequisiteConfiguration.xml
trunk/Assets/Configs/XML/Generated/Regions.xml

Main Configuration File

trunk/Assets/Configs/XML/Configuration.xml

 

The Hunt files are where you define what and how many animals will appear in any particular hunt. In it, you can define challenges, animals
speeds, and spawn delays, among other parameters. The XSLX file is where you'll be doing this work. Once done, you will then export the Excel
sheet into Hunt.xml and Spawners.xml and then you convert them into the Configuration.xml file (more on that later). 

The Animals sheet has multiple tabs, each corresponding to each XML file generated. Please see   Adding Animals To The Hunt & Animal Sheets
and   for more details.Adding Antlers, Horns, & Tusks to Animals

The Region sheet defines the number of stars in a region, the number of hunts, the type of weapon any particular hunt will use, and where trophy
& dog hunts will appear. Exporting this file will export to both the Regions.xml and the PrerequisiteConfiguration.xml where the prerequisite
defines where trophy hunts will unlock dog hunts.

The main configuration file is the one file that we upload to the server (in our case, we upload to our variant server). Once you're satisfied with you
edits (they can be in any or all of the above XLSX files that your've already converted), you can Generate Configurations. This will grab everything
in your local Configurations folder and generate the Configuration.xml and integrates everything in the Configs folder into this one file. That's why
its always important to Sync to the Configs folder before hitting Generate Configuration.

Converting XLSX Files & Generating Configuration.xml

The following assumes Hunt_Region_2.xlsx, hunt.xml, and spawners.xml are checked out. When done with editing Hunt_Region_2.xlsx, you
need to convert it to the XML files. Go to the menu Configuration > Specific > Hunt. 

https://confluence.glu.com/pages/viewpage.action?pageId=72625808
https://confluence.glu.com/pages/viewpage.action?pageId=74785847


 

This will start the conversion process. Unity will be frozen during this time. When done, you'll see a pair of messages in the console:

 

Now sync to the Config folder and then Generate Configuration by going to menu Configuration > Generate Configuration and you should see this
message in the console:



 

Now you can upload the configuration up to your variant (see the next section below on how to create a variant).

Checking In/Out Files

All of our Hunt_Region_#.xlsx and other configs (Animals.xlsx, Regions.xlsx) files are on exclusive checkouts. 

Their associated .xml files, however, are not exclusive. This is ok since they will be sync'd and exported by other users and xml files can be
merged. xlsx files can't.

When checking out a hunt file, you also need to check out the hunt.xml and spawners.xml plus (and this is the case for all types of configs you
work on) the configurations.xml file.

File structure 
Assets/Configs/XLS/Hunts/(region hunt files)
Assets/Configs/XML/Generated/(xml files)

For Hunt_Region_#.xlsx, check out the following xml files:
Spawners

For Animals.xlsx, check out the following xml files:
AnimalAnimationConfigurations.xml
AnimalBaseConfigurations.xml
AnimalConfigurations.xml
AnimalPartConfigurations.xml
AnimalVariationConfigurations.xml
Note: each of these animal configs have a corresponding tab in the Animals.xlsx sheet

For Regions.xlsx, check out these xml files:
Region.xml
PrerequisiteConfiguration.xml

Be sure to follow the procedures below for Uploading Data to the Server to test before checking in your xlsx file. Write an adequately detailed
changelist note summarizing your edits.

Uploading Data to the Server
Always upload your data to a variant. To start a variant, start the game from Scene Startup in Unity and follow these steps:

   Creat a Variant

From the Main Menu, click on TEST/QA (in red outline)



This opens up the TEST MENU. Click on the DEBUG MENU button (in red outline).

This opens up the DEBUG MENU. Click on the GAME VARIANT field and type in a name for your variant.



Now type in a variant name of your choosing in either all caps or all lower case and click on SAVE. Remembering if you typed in all caps
or lower case is important when typing in your variant name in the admin panel (more on this later).

Note: even if you're in lower case, the text will show in all caps



Anytime you open the DEBUG MENU (even if you've closed Unity), your variant should be persistent. Check by opening the DEBUG
MENU
Note the - in front of the variant name. This is autogenerated, so don't add it yourself

Using Your Variant
Your variant is ready to be used. Open up the GameServerAdmin panel here: http://dh-dev-admin.glupen.studio.glulive.com:8081/game_

. It should look like this:configuration

Enter the current game version and your variant, e.g. 0.5.0-jkung2, with no spaces and hit Select. After it loads, your page should look
like this:

http://dh-dev-admin.glupen.studio.glulive.com:8081/game_configuration
http://dh-dev-admin.glupen.studio.glulive.com:8081/game_configuration


Note, if this is your first time, you won't have any xml text in the right panel until you've uploaded your configuration.xml file.
Now let's get your configuration converted to XML (assuming you've already made your edits). Go to Unity > Configurations and select
the configs you want to convert.

Once you're done converting all the configs you want, make sure to sync to the latest in the
Configurations folder in P4 (so you don't blow out anyone else's work) BEFORE clicking on



Generate Configurations.

Quickly Generate Configurations now. Clicking on Generate Configurations takes all of the various configurations you may have worked
on and any that you sync'd to and combines it all into one XML file, Configuration.xml.

Now you can upload your Configuration.xml file up to the server. 
Click on Choose File
Navigate to Assets  Configs  XML and choose Configuration.xml and click on Choose (or you can double click on
Configuration.xml)

When Configuration.xml shows up next to the Choose Files button, you're ready to upload. Click on Upload.

Playing The Game

Launch

Go to Scene > Start from Startup to launch the game.

 

Pause

At the top center of Unity, there are a set of 3 buttons. Play, Pause, and Step Forward

 

The pause button will pause the game and automatically toggle the Scene tab on. (If off the game board, select a game object you know is in the
level and hit F with the Scene window active). 



This will allow you to see the spawned animals, their splines, and the direction they're moving on the splines. You can also step through each
frame by hitting the step through button. 

This is super helpful for debugging issues with stuck animals and such.

 

Reporting Issues

Any issues that arise either in-game or in the editor that block you or is a significant impediment to your progress, follow this procedure:

Notify Rita Mae 
She will contact the appropriate engineer and follow through

If Rita isn't available, contact Bryce or Sap
If none of the above are around, then create a JIRA ticket and slack Rita Mae the link
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